Showing results for 
Search instead for 
Do you mean 
Reply
Upgrade Ace
DaZ
Posts: 86
Registered: ‎08-07-2009
0

How to regain some lost speed back (1819).

I came across this generic routine to regain some lost speed for firmware 1819. (works for RAID as well).

 

I could fully explain it all here but it was guy called Tony over on the OCZ forum that originally came up with this.

So not to steal his thunder or upset anyone I will simply link to his post which explains it perfectly.

 

http://www.ocztechnologyforum.com/forum/showthread.php?t=64753

 

I have tried this myself and my M225 write speed has vastly improved as a result. :smileyhappy:

 

 

 

 

JEDEC Jedi
targetbsp
Posts: 7,561
Registered: ‎08-27-2009
0

Re: How to regain some lost speed back (1819).

[ Edited ]

I posted some of my observations on it here: http://www.forum.crucial.com/t5/Solid-State-Drives-SSD/Question-Is-there-an-issue-with-1819-FW-causi...

 

It does work well but as with all these tricks - only temporarily (24 hours in my case!)  I don't know if you've seen but at the end of the Reaction to Tony Trim thread they are now suggesting it's a firmware fault that Indilinx are now aware of.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Upgrade Ace
DaZ
Posts: 86
Registered: ‎08-07-2009
0

Re: How to regain some lost speed back (1819).

[ Edited ]
in reply to targetbsp

There is only a couple of replies to that post targetbsp and ton of thank yous.

 

Benchmarked again this morning, my writes are still far better than they were before.

I will keep on monitoring though.

SODIMM Sherpa
sonicsonic
Posts: 66
Registered: ‎10-01-2009
0

Re: How to regain some lost speed back (1819).

The Method above does not work for me it did all much worse i neded to run 2 times wiper in order to restore to speed i had before no improvement whats o ever

JEDEC Jedi
targetbsp
Posts: 7,561
Registered: ‎08-27-2009
0

Re: How to regain some lost speed back (1819).

in reply to sonicsonic

Yeah those steps alone slowed mine down to the lowest levels I've ever seen but following it with a wiper made it the fastest I'd ever seen. So at least one of those steps was beneficial when used prior to wiper.

However, I don't think it's worth doing any of those or any other performance restoring steps now.  They all take a lot of time, don't last and it's now known to be a firmware issue so presumably nothing we can do will hold any long term fix.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Binary Boss
uneverno
Posts: 38
Registered: ‎09-09-2009
0

Re: How to regain some lost speed back (1819).

I reinstalled the 1819 firmware and gave this a try. IT WORKS. Thank god for Tony at OCZ. However, isn't it typical that a fix to our problem with the TRIM firmware came from someone at OCZ and not a single word from Crucial here in the way of help. Looks like we need to check the OCZ forums if we have a problem because there certainly is nothing worth looking at here. I'll be back if or when OCZ has a new WORKING firmware (which we'll probably have to find another work around for at OCZ.

 

Great post to the OP.

Binary Boss
Brian
Posts: 27
Registered: ‎10-02-2009
0

Re: How to regain some lost speed back (1819).

in reply to uneverno

After seeing the post Target made on this subject I performed the process on my raid, (a hybrid with a Vertex 60gb and a Crucial M225), and the performance improved, not as it was but pretty close. (I had flashed back to 1571 on the Crucial, the Vertex at 1.41 with the built in GC). The performance has maintained but it is very early days yet, but I read that to perform this on the active partition while booted from it may not work properly, (at least that is how read the post), so as I have multiboot into Windows 7, Vista x64 and Windows XP, I repeated the process from Vista on the raid SSD. All worked OK but the results were exactly the same as when I did it from Windows 7. I will now monitor the situation.

I will not comment again on the level of Crucial input to this forum, I have had my say and did get a response, but I see little if any change, but the forum is clearly moderated. :smileyindifferent:

SODIMM Sherpa
Tekno
Posts: 89
Registered: ‎10-20-2009
0

Re: How to regain some lost speed back (1819).

[ Edited ]
in reply to Brian

Well, apparently Crucial's stance on their forums is for us to help each other. It's not really a means for them to come help us. Ain't that something? They expect us to help each other when we have hardly any insight into the drive or firmware. If they really want us to help each other, they need to release all release notes for the firmware with in depth detail of how it works, so we can figure out how we can fix things ourselves if they are unwilling to help. Unfortunately, hardly anything is released. Instead, we are left to just take shots in the dark hoping to find a solution which they then can use to tell other customer. The word guinea pig comes to mind.

 

At any rate, hopefully the guys at OCZ and Indilinx can figure all of this out so we can get our Crucial drives working again.

SODIMM Sherpa
Tekno
Posts: 89
Registered: ‎10-20-2009
0

Re: How to regain some lost speed back (1819).

in reply to Tekno

The OCZ guys suggest that using the Garbage Collection firmware is also a solution to the slowdown issue of the TRIM only firmware (1819). Hopefully, Crucial will get their testing of it done and release it. It's been in their labs for a while. A month or so. It would be nice if we could get some status of how it's going or what issues they are seeing causing a delay.

JEDEC Jedi
targetbsp
Posts: 7,561
Registered: ‎08-27-2009
0

Re: How to regain some lost speed back (1819).

[ Edited ]
in reply to Tekno

The last concerns I saw over the GC firmware was increased power consumption and drive wear.  With regards to power consumption it would be nice to have the choice cause a lot of us run the drives in desktops.  As for wear again I'd like the choice - I'd rather have it fast now and a shortened life cause I suspect I will be replacing the drive with something bigger and faster long before it expires.  As they come with a 5 year warranty though I can understand their concern that it lasts at least 5 years!  Anyway, however much extra wear it'd put on will probably be less than us all running wipers, reinstalls, defrags, becnhmarks etc on a near daily basis trying to get our performance back lol.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!