MacBook Pro Restore Error, help !

Highlighted
Kilobyte Kid

MacBook Pro Restore Error, help !

I have a MacBook Pro 13" mid 2012, i am trying to clone HDD to Crucial SSD 525GB MX300 2.5", i have followed Crucial Install / restore guidlines to the letter, format SSD with no problem but when i try to restore HDD to SSD i get the following error message :-

 

Validating Target

Validating Source

Could not recognize "/dev/ (null)" as an image file

Could not retrive scan information - invalid argument

operation failed

 

Any ideas guys ?, please help, this is driving me nuts. thanks.

3 Replies
Kilobyte Kid

Re: MacBook Pro Restore Error, help !

If you have never replaced the hard drive cable, then I would highly recommend this be your first step as this model was known to have a very high failure rate for these cables.   Apple even had a free replacement program available for a while, but is now expired for most people.   The cable is inexpensive and the failures could show in many different ways.

 

I haven't read Crucial's instructions for cloning drives, so what software was being used?   I've always been partial to Carbon Copy Cloner.   Another option for you would be to do a fresh install on the SSD then migrate your data over using Migration Assistant.

 

Kilobyte Kid

Re: MacBook Pro Restore Error, help !

Thank you, i've been told about the cable and i have one on order, super cheap,

Crucial instructions are to use the built in utility disc restore, i've not used any clopy software and not sure where to get it from,

As you can tell i'm a complete bonehead with technology but this upgrade seemed so easy that i thought i'd give it a try, Big mistake i think.

Kilobyte Kid

Re: MacBook Pro Restore Error, help !

If I were you, I would just do a clean install of OSX/macOS on the SSD.   Now the installer will not show your new SSD since it is blank.  Just go up to the menus and there will be an option to launch Disk Utility.  If installing High Sierra, you won't see the blank drive in the Disk Utility GUI (its a new bug/feature).  There is a drop down list menu just above the device column where you can select "Show all devices" or something like that.  Select it and then close Disk Utility & relaunch it.   You should now see your new blank SSD as a device.    Partition/Erase the new SSD and then quit Disk Utility to return to the installer.  Your new SSD should now show up as a destination option.   

 

After the actual install finishes and it reboots into the new OS don't create any user accounts.   Connect the original hard drive externally.  Then proceed through the OS setup instructions and it will offer to use Migration Assistant to transfer your old User Account to the new SSD.   It may take a little exploration in the Migration Assistant interface to be able to transfer your old User Account since it usually expects you to be transferring it from another computer and not a locally connected drive.

 

This option gives you a fresh OS, but still retains your User account settings and documents.   If Migration Assistant won't let you transfer from the original drive, then you can just create a new User account and manually copy the documents over to your new account.

 

If the above doesn't work for you, you can always go back and do a restore as Crucial describes.   I personally have had trouble using Disk Utility in this situation (sometimes it just works, other times it won't)  and I'm not sure if it copies your Recovery Partition which is needed for FileVault.    I personally like Carbon Copy Cloner as it will also copy your Recovery Partition and it can also be used to just copy files and create backup  images.

 

Carbon Copy Cloner website:

https://bombich.com

 

Don't give up.   We all go through the same thing regardless if we are an "expert" with tech or not.   It is always a learning experience and by doing this you are getting a better understanding of your computer and also an appreciation of what technicians go through.