Storage Executive won't load

Bit Baby

Storage Executive won't load

Hello everyone

Have been unable to get Crucial Storage Executive to run. The splash screen shows up then about 5 seconds later disappears. No clues in task manager, it doesn't even show up there while splash screen is up. There is a small sign of activity but it goes away.


The version number is 3.,4something. Downloaded yesterday.


Have unistalled then reinstalled it, no joy.


Windows 10 Pro with most recent upgrades. Java just updated. 32GB ram, Crucial MX300 525 SSD as D:\ drive (host drive for two virtual machines). Asus P8Z77xxx mobo with i7 2600K. C:\ and E:\ drives are both pci-e X4 drives, there is an additional 2TB spinning HDD partitonend into 3 logical drives. The drive itself is operational.



2 Replies
Community Manager

Re: Storage Executive won't load

@kullboys I am sorry for the issues you've experienced with Storage Executive. What are you wanting to use Storage Executive for? 


We would suggest doing the following: 

  • Uninstall Storage Executive, delete installation folder in Program files and then download and install the latest version.
  • Right click Storage Executive Icon and 'run as administrator'.

Please let us know if you are still running into to problems with Storage Executive after completing these steps. 

YogiH, Crucial Moderator, US

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Storage Executive won't load

I'm having an issue wtih CSE too...

I installed, it crashed.


I tried to open it again, and I can't find the software to either launch or uninstall...


I tried to install again, but I keep getting an error that it's already installed.


I want to activate momentum cash as the typing etc is a  bit laggy...


Can anyone help?


I'm running a recently updated version of windows 10s. I'm using the Crucial 120gb SSD (just got it).