Reply
Binary Boss
pkincy
Posts: 43
Registered: ‎04-11-2011
1
Accepted Solution

Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

I have a new Lenove W520 Quad Core Sandy Bridge laptop.  After receiving it this weekend I immediately installed a new Crucial C300 128GB SSD (firmware is 006) and did a clean install.  Or at least a Lenovo Rescue and Recovery replacement of the factory image on the new C300.

 

I did all the suggested tweaks as well.  AHCI, no superfetch, no defrag, no Prefetch, no write caching,etc.

 

I have the latest Intel driver on the SATA III controller.

 

My read speeds on both CrystalDiskMark v3.01 and on AS SSD are a bit low but in the ballpark for this drive.  My write speeds are very low.  Sequential write is in the 90 Mb/s range, but the real problem is the important 4k marks.

 

On both CrystalDiskMark and AS SSD the 4k reads are 4 Mb/s both in the 4k and the 4k-64Thrd.  And this seems terribly low.  AS SSD shows the drive as OK aligned.

 

I would post a screen shot of both, but need directions on how to do that.

 

Has anyone seen write speeds this low on a properly operating C300 128GB SSD?

 

Perry

Perry

Lenovo W520, I7 2720QM, Crucial M4 512 GB OS/boot, Crucial M4 256 GB Optibay, Intel 80 GB mSata, Q1000M Graphics

Lenovo X220, I7 2620, Samsung 830 Pro SSD,
Intel 80 GB 310 mSata, Intel HD 3000 Graphics

Asus P8Z68-V Mobo, I7-2600K, Radeon HD 6870, 1TB WD Sata 3, C300 256 GB OS Drive; C300 128 GB Data Drive
JEDEC Jedi
targetbsp
Posts: 6,998
Registered: ‎08-27-2009
1

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

On a desktop you;d be getting close to 140 sequential write but I've not actually seen any benchmarks from a sandy bridge laptop (until now!) so I'm not sure how agressive the power saving is in it.

 

Does AS SSD show it as aligned OK?  ie. Is the number in the top left green?

Next thing to check is that write cache is enabled in device manager for the drive.

Do you have the Intel Rapid Storage drivers?

 

If all those are OK then it's probably power saving features of the laptop.  There were registry tweaks for older laptop chipsets but I'm not yet sure how relevant they are for sandy bridge.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

JEDEC Jedi
lsdmeasasp
Posts: 4,404
Registered: ‎09-16-2009
2

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

[ Edited ]

Yes, 4MB/s is WAY WAY to low!!

 

To upload an image here you click the little image of a tree in the editor, then either upload the image directly (Will need to wait for moderator approval), or use the "From another site" tab and upload the image to another imagehost like imgur or photobucket, then put the direct URL into the top section of the from another site tab.  Then hit load image, then insert image, then done.

 

I would like to see your image results, but it sounds like the non clean install process may have caused some of the issues?   Did you enable write back cache in either device manager or the RST program for the drive?   If not do that now.

 

In regards to what Targetbsp mentioned above, what power plan do you have enabled in the OS power plan settings?   Have you, or can you, disable speedstep in the BIOS (C1E and EIST)

 

Can you link me to the specifications and download page for your laptop so I can check a few things and also look into your BIOS.  All I can find is the buy/shop pages, or news about it's release  :smileyvery-happy:

 

Actually, I found the specs, can you show me your drivers download page so I can look at your BIOS, thanks!   Well kinda found them I guess, the PDF I found does not show all specs.   Can you tell me what chipset the board has, you can check with AIDA64 trial or HWmonitor

http://www.aida64.com/

http://www.hwinfo.com/download32.html

DIMMented
namaiki
Posts: 112
Registered: ‎11-24-2010
1

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

As the others have said, you will want to enable the write cache.

 

In fact, you don't really have to do anything for SSDs besides check alignment and make sure that AHCI is enabled.

Binary Boss
pkincy
Posts: 43
Registered: ‎04-11-2011
0

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

Thank you all.  In my googling of all the things to do in the registry, in services.msc and in drive properties I had come across conflicting advice on the Enable Write Cache and it was not checked.

 

After enabling write cache my AS SSD benchmarks went up 10 fold on the 4k writes and my 4K-64thrd writes went up 22 fold.

 

My drive is now showing good benchmarks on both reads and writes.

 

I will work on posting both the before and after benchmarks to show the difference.

 

Perry

 

Perry

Lenovo W520, I7 2720QM, Crucial M4 512 GB OS/boot, Crucial M4 256 GB Optibay, Intel 80 GB mSata, Q1000M Graphics

Lenovo X220, I7 2620, Samsung 830 Pro SSD,
Intel 80 GB 310 mSata, Intel HD 3000 Graphics

Asus P8Z68-V Mobo, I7-2600K, Radeon HD 6870, 1TB WD Sata 3, C300 256 GB OS Drive; C300 128 GB Data Drive
Binary Boss
pkincy
Posts: 43
Registered: ‎04-11-2011
0

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

Here is the before "Write Cache Enabled"

 

Perry

Lenovo W520, I7 2720QM, Crucial M4 512 GB OS/boot, Crucial M4 256 GB Optibay, Intel 80 GB mSata, Q1000M Graphics

Lenovo X220, I7 2620, Samsung 830 Pro SSD,
Intel 80 GB 310 mSata, Intel HD 3000 Graphics

Asus P8Z68-V Mobo, I7-2600K, Radeon HD 6870, 1TB WD Sata 3, C300 256 GB OS Drive; C300 128 GB Data Drive
Binary Boss
pkincy
Posts: 43
Registered: ‎04-11-2011
0

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

Here is after "write cache enabled"

 

Perry

Lenovo W520, I7 2720QM, Crucial M4 512 GB OS/boot, Crucial M4 256 GB Optibay, Intel 80 GB mSata, Q1000M Graphics

Lenovo X220, I7 2620, Samsung 830 Pro SSD,
Intel 80 GB 310 mSata, Intel HD 3000 Graphics

Asus P8Z68-V Mobo, I7-2600K, Radeon HD 6870, 1TB WD Sata 3, C300 256 GB OS Drive; C300 128 GB Data Drive
Binary Boss
pkincy
Posts: 43
Registered: ‎04-11-2011
0

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

[ Edited ]

And my apologies.  For some reason the Photobucket image would not load at small or medium size settings.

 

So I am not really trying to shout at you.

 

Should the "turn off windows write cache buffer" box be checked also or not?

 

Thanks again to all for the solution.

 

Perry

Perry

Lenovo W520, I7 2720QM, Crucial M4 512 GB OS/boot, Crucial M4 256 GB Optibay, Intel 80 GB mSata, Q1000M Graphics

Lenovo X220, I7 2620, Samsung 830 Pro SSD,
Intel 80 GB 310 mSata, Intel HD 3000 Graphics

Asus P8Z68-V Mobo, I7-2600K, Radeon HD 6870, 1TB WD Sata 3, C300 256 GB OS Drive; C300 128 GB Data Drive
JEDEC Jedi
targetbsp
Posts: 6,998
Registered: ‎08-27-2009
1

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

The last tick makes no difference on mine (in benchmarks at least) and it does state its an added risk to your data if you don;t have a ups (which I don't) so i leave it unticked.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

JEDEC Jedi
lsdmeasasp
Posts: 4,404
Registered: ‎09-16-2009
0

Re: Is 4 Mb/s for 4k and 4k-64thrd writes bad on a new C300 128 GB SSD

[ Edited ]

That looks MUCH better!   But the 4K is still low, did you try the power settings in the OS and BIOS we suggested above?

 

There not really bad or anything, and could be normal for a laptop, just asking about that to ensure you tried everything to get them as high as they will go.