Reply
Binary Boss
gisenberg
Posts: 11
Registered: ‎10-25-2009
0

Problems booting from Boot Camp partitions on M225

[ Edited ]

Hi all,

 

I purchased a Crucial CT128M225 SSD on October 19th for my early 2008 17" MacBook Pro this week (Boot ROM: MBP41.00C1.B03). I'm currently running OSX 10.6.1. The Apple EFI 1.7 Firmware Updater says the update does not apply to this machine.

 

I'm not sure what firmware is on the SSD, but it is one of the models that has the "flip this switch to enable firmware updating" mechanism. I've attempted to update the drive's firmware with no luck. The firmware flashing tool reports that there are no matching drives found.  

 

In OSX, everything works great. However, when trying to boot into any sort of Windows or DOS environment (such as a bootable FreeDOS CD image for updating firmware), the machine freezes at startup and I'm stuck at a gray screen of death. This includes booting from a BootCamp partition, booting from a Windows partition or booting from a Windows 7 install CD.

 

This behavior reproduces consistently. If I replace the SSD drive with my old spindle drive, the machine functions as normal and I'm able to boot from Boot Camp partitions again.

 

Any ideas?

 

edit: Running firmware 1517

 

edit: Updated to firmware 1819. This appears to be a duplicate of a similar issue seen on this thread, but with a different SSD: http://www.ocztechnologyforum.com/forum/archive/index.php/t-54425.html

 

It looks like the MacBook 1.7 EFI Firmware updater won't update this machine, and that update is what would resolve the issue.

Binary Boss
gisenberg
Posts: 11
Registered: ‎10-25-2009
0

Re: Problems booting from Boot Camp partitions on M225

Just updated to firmware 1819. The flash switch was a red herring. While the switch was set, the drive reported itself as a Yatapon Barefoot ~150gb drive and the firmware update couldn't find the Crucial drive.

 

I had to leave the switch as factory default in order to flash it.

 

I'm still seeing the same issues on firmware 1819.

 

Anyone?

Binary Boss
gisenberg
Posts: 11
Registered: ‎10-25-2009
0

Re: Problems booting from Boot Camp partitions on M225

Long story short, it looks like the MacBook EFI 1.7 Firmware update addresses this issue, but the firmware isn't extended to early 2008 MacBook Pros.

 

Looking at the OCZ thread, they use the same Indilinx Barefoot chipset and run into the same problems. Specifically, v1.3 of the Indilinx firmware exhibits this problem.

 

Any idea if this is on the radar for the next Indilinx firmware / Crucial M225 firmware revision? It's the difference between selling my MacBook or keeping it around.