Reply
Kilobyte Kid
laurstig
Posts: 2
Registered: ‎10-22-2012
0
Accepted Solution

SOLVED: Crucial v4 CT256V4SSD2 disastrous performance

[ Edited ]

Hi All,

 

any suggestions how to improve SSD perfomance.

 

installed clen Win7 (SSD is in AHCI) and system' s performance is very poor - switching between app is slow... etc.

here are Windows System Assessment Tool results (took  1/2h ) - as you see there is "some" problems with it 

 

> Running: Feature Enumeration ''
> Run Time 00:00:00.00
> Running: Storage Assessment '-seq -read -n 0'
> Run Time 00:01:16.78
> Running: Storage Assessment '-ran -read -n 0'
> Run Time 00:01:02.01
> Running: Storage Assessment '-scen 2009 -drive C:'
> Run Time 00:18:26.55
> Running: Storage Assessment '-seq -write -drive C:'
> Run Time 00:01:39.50
> Running: Storage Assessment '-flush -drive C: -seq'
> Run Time 00:03:58.71
> Running: Storage Assessment '-flush -drive C: -ran'
> Run Time 00:04:56.46
> Running: Storage Assessment '-hybrid -ran -read -n 0 -ransize 4096'
NV Cache not present.
> Run Time 00:00:08.97
> Running: Storage Assessment '-hybrid -ran -read -n 0 -ransize 16384'
NV Cache not present.
> Run Time 00:00:01.01
> Disk Sequential 64.0 Read 233.43 MB/s 7.4
> Disk Random 16.0 Read 120.00 MB/s 7.3
> Responsiveness: Average IO Rate 20.59 ms/IO 2.9
> Responsiveness: Grouped IOs 27.01 units 1.9
> Responsiveness: Long IOs 72.45 units 1.9
> Responsiveness: Overall 1956.65 units 1.9
> Responsiveness: PenaltyFactor 1.0
> Disk Sequential 64.0 Write 193.88 MB/s 7.3
> Average Read Time with Sequential Writes 37.055 ms 1.9
> Latency: 95th Percentile 155.970 ms 1.9
> Latency: Maximum 642.333 ms 1.9
> Average Read Time with Random Writes 35.853 ms 1.9
> Total Run Time 00:32:16.18

 


partitions are aligned:


DISKPART> list part

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Primary 100 MB 1024 KB
Partition 2 Primary 238 GB 101 MB

 

 

running on Samsung Q330 notebook (upgraded to 8gb ram)

 

 

any ideas/help would be really appreciated!

 

thanks.

 

Lauris

 

Bit Baby
millsaz
Posts: 1
Registered: ‎10-22-2012
0

Re: Crucial v4 CT256V4SSD2 disastrous performance

I just installed the Crucial v4 CT256V4SSD2 on a Intel i5 machine with 16 GB of PC3-10600 RAM and I can't believe how terrible the performance is.... After a longer than normal Windows 7 Pro 64bit installation I am about to pull the drive and return it to the vendor for a refund.  My WD Caviar performs better!!!  Also I didn't use AHCI and the performace is terrible in SATA mode so I won't even attempt to switch to AHCI.

 

Any help on this matter would be greatly appreciated before I return it!

 

Memory Leak Geek
Jim_TheCru
Posts: 10
Registered: ‎05-02-2012
0

Re: Crucial v4 CT256V4SSD2 disastrous performance

So what is exactly wrong with your drive? You are getting the correct sequential read and write speeds. 

 

Disk Sequential 64.0 Read 233.43 MB/s 7.4

 

Disk Sequential 64.0 Write 193.88 MB/s 7.3

 

These speeds are consistant with what I have seen.

 

So where is the issue?

Find more helpful tips here -
thecru.crucialcommunity.com


Memory Leak Geek
Jim_TheCru
Posts: 10
Registered: ‎05-02-2012
0

Re: Crucial v4 CT256V4SSD2 disastrous performance

Can you be more specific as to what you consider to be terrible performance? What type of system, you are very vague. I need more information if I am to help you.

 

System specs are a must

 

AHCI is what you are supposed to be running any SSD.

 

 

 

Find more helpful tips here -
thecru.crucialcommunity.com


Kilobyte Kid
laurstig
Posts: 2
Registered: ‎10-22-2012
0

Re: Crucial v4 CT256V4SSD2 disastrous performance

[ Edited ]

fianlly solved the problem - 

 

I downloaded and upgraded "ORIGINAL" "intel 5 series 4 port sata ahci controller " driver to the latest one.

Win7 had automaticly installed their dirver - which was quite "old" one - year 2009.  after update - everything was flying as supposed to :smileyhappy:

 

after this "update"  I have following stats:

 

> Disk Sequential 64.0 Read 231.00 MB/s 7.4
> Disk Random 16.0 Read 71.88 MB/s 6.9
> Responsiveness: Average IO Rate 0.98 ms/IO 7.9
> Responsiveness: Grouped IOs 8.77 units 7.4
> Responsiveness: Long IOs 4.96 units 7.7
> Responsiveness: Overall 43.45 units 7.2
> Responsiveness: PenaltyFactor 0.0
> Disk Sequential 64.0 Write 198.66 MB/s 7.3
> Average Read Time with Sequential Writes 3.308 ms 6.5
> Latency: 95th Percentile 7.360 ms 6.1
> Latency: Maximum 543.338 ms 2.7
> Average Read Time with Random Writes 2.813 ms 6.6
> Total Run Time 00:01:16.71

 

 

 

and the big difference:

Before update: Total Run Time 00:32:16.18

After update:     Total Run Time 00:01:16.71

 

thanks to all - problem solved!